BGP Configuration IBGP/EBGP

Basic BGP topology First connecting Neighbors(IBGP)

 

R1 Interfaces

Lo1-1.1.1.1/32

F0/1 – 192.168.2.1/30

F0/0 – 192.168.1.1/30

 

R3 Interfaces

Lo3-3.3.3.3/32

F0/0-192.168.2.2/30

 

R4 Interfaces

Lo4- 4.4.4.4/32

F0/0 – 192.168.1.1/30

F0/1 – 192.168.3.1

 

R2 Interfaces

Lo2 – 2.2.2.2/32

F0/0 – 192.168.3.2

 

 

 

From R1

 

Router BGP 6500

Neighbor 192.168.1.2 remote-as 6500

Neighbor 192.168.2.2 remote-as 6500

 

From R4

Router BGP 6500

Neighbor 192.168.1.1 remote-as 6500

Neighbor 192.168.2.2 remote-as 6500

 

From R3

Router BGP 6500

Neighbor 192.168.2.1 remote-as 6500

Neighbor 192.168.1.2 remote-as 6500

 

 

 

 

 

Using Loopbacks as Destination addresses

 

R1

r1(config)#

r1(config)#router eigrp 1

r1(config-router)#network 1.1.1.1 0.0.0.0

r1(config-router)#network 192.168.0.0 0.0.255.255

 

R3

r3(config)#router eigrp 1

r3(config-router)#network 3.3.3.3 0.0.0.0

r3(config-router)#network 192.168.0.0 0.0.255.255

 

R4

r4(config)#router eigrp 1

r4(config-router)#network 4.4.4.4 0.0.0.0

r4(config-router)#network 192.168.0.0 0.0.255.255

 

Now, for the BGP Setting.  Now we will configure R4 and R3 as bgp neighbors.  They do not have to be directly connected as long as they are reachable on the network.  We will not use the interface ip address of R3 or R4 we will simply use the loop back addresses.  We only have one connection to each routers but if we had redundant connections loop back addresses are a much better idea…. But the problem here is they have to be reachable via the IGP in this case EIGRP.

 

 

 

From R4

 

r4#ping 3.3.3.3

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 120/209/316 ms

r4#

 

r4(config)#router bgp 6500

r4(config-router)#neighbor 3.3.3.3 remote-as 6500

r4(config-router)#neighbor 3.3.3.3 update-source lo4

 

 

From R3

r4(config)#router bgp 6500

r4(config-router)#neighbor 3.3.3.3 remote-as 6500

r4(config-router)#neighbor 3.3.3.3 update-source lo4

r4(config-router)#

*Mar  1 04:53:53.706: %BGP-5-ADJCHANGE: neighbor 3.3.3.3 Up

 

 

r4#sh ip bgp sum

BGP router identifier 4.4.4.4, local AS number 6500

BGP table version is 1, main routing table version 1

 

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd

3.3.3.3         4  6500       5       5        1    0    0 00:02:08        0

 

We have to use the Update-source loopback command.

 

The reason why is when BGP peers with a neighbor it expects the update to come from that source address.

 

When 4.4.4.4 sends out an update to 3.3.3.3 this is what it will show in the packet

Source 192.168.1.2

Destination 3.3.3.3

 

BGP will discard that packet since it did not come from 4.4.4.4

 

By updating source it can come out of any interface we would like it to it will have a source of 4.4.4.4

 

Also keep in mind it has to be reachable, through static,eigrp,ospf etc etc if it is reachable it can become a IBGP neighbor.

 

 

 

 

 

Configuring EBGP

 

 

From R4

 

r4(config-router)#neighbor 2.2.2.2 remote-as 6400

r4(config-router)#neighbor 2.2.2.2 update-source lo4

r4(config-router)#neighbor 2.2.2.2 ebgp-multihop 5

r4(config-router)#

*Mar  1 06:15:04.866: %BGP-5-ADJCHANGE: neighbor 2.2.2.2 Up

 

 

From R2

 

 

r2(config-router)#neighbor 4.4.4.4 remote-as 6500

r2(config-router)#neighbor 4.4.4.4 update-source l02

r2(config-router)#neighbor 4.4.4.4 ebgp-multihop 5

r2(config-router)#

 

 

 

The same has to be done here with the Update-source since it will come from each interface.  The other command we are using here since it Is EBGP It HAS TO BE DIRECTLY CONNECTED!  With EBGP even if a destination is reachable it has to be connected directly.  In my case I simply did static routes to each.. we could use a IGP but its pointless.  But they have to be directly connect.

 

At that point since we are using Loopbacks in case of redundancy.  I have only 1 outgoing interface but in some cases ISP’s / CE routers might have 2 or 3 connections if they are all static routes they will all load balance.  Also this is where a loop back is good to use if one of the directly connected routes would go down.

 

Any time we peer with Loopbacks we must use the EBGP-Multihop command the #5 used in my command is simply the amount of hops to use.

 

 

 

 

Advertisements
Post a comment or leave a trackback: Trackback URL.

Comments

  • puran  On November 22, 2010 at 1:15 am

    Hi
    sir /mam i want ccna icnd1nd icnd2 real videos plz send me i am pay next month

  • puran  On November 22, 2010 at 1:16 am

    Hi
    sir mam i want ccna videos icnd 1 icnd 2 pls send me ,,,,,,

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: