How to configure a 2511 Terminal server.

Terminal servers cut down a huge amount of time in a test lab and in the real world where if you lock yourself out of a machine you are telnet/ssh’d into it does not matter since you have console access. In my lab I have a 2511, before I configured it it took me a while to find the best configuration.

TermServer#sh run
Building configuration…

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname TermServer
!
no logging console
enable secret 5 $1$t4HZ$dGywOHBSeYs37rzn1mFGZ1
!
!
!
!
!
ip subnet-zero
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
no ip directed-broadcast
!
interface Ethernet0
no ip address
!
interface Serial0
no ip address
no ip directed-broadcast
shutdown
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
ip classless
no ip http server
!
!
menu access-server text 1 3600 Router
menu access-server command 1 telnet 1.1.1.1 2001
menu access-server text 2 Switch-C 1800 series router
menu access-server command 2 telnet 1.1.1.1 2002
menu access-server text 3 Switch-C 3600 series (2)
menu access-server command 3 telnet 1.1.1.1 2003
menu access-server text 4 3650 swouter
menu access-server command 4 telnet 1.1.1.1 2004
menu access-server text 5 3550 swouter
menu access-server command 5 telnet 1.1.1.1 2005
menu access-server text 6 Router-B 2800
menu access-server command 6 telnet 1.1.1.1 2006
menu access-server text 7 Agg Switch
menu access-server command 7 telnet 1.1.1.1 2007
menu access-server text 8 Router-D 3640
menu access-server command 8 telnet 1.1.1.1 2008
menu access-server text 9 Disconnect (Use this to kill sessions to lab devices)
menu access-server command 9 disconnect
menu access-server text 10 Drop to EXEC mode
menu access-server command 10 menu-exit
menu access-server clear-screen
menu access-server line-mode
!
line con 0
autocommand menu access-server
transport input none
line 1 8
no exec
exec-character-bits 8
transport preferred none
transport input all
telnet break-on-ip
telnet ip-on-break
autohangup
stopbits 1
flowcontrol software
line 9 16
line aux 0
line vty 0 4
no login
autocommand menu access-server
!
end

When logged into the server under the IP address 10.100.249.247 I get the following selection.

1 3600 Router
2 Switch-C 1800 series router
3 Switch-C 3600 series (2)
4 3650 swouter
5 3550 swouter
6 Router-B 2800
7 Agg Switch
8 Router-D 3640
9 Disconnect (Use this to kill sessions to lab devices)
10 Drop to EXEC mode

Selection:

By entering one of the numbers I will be able to console directly into that box like I am sitting there with my laptop consoled into the device. 10 drops me right back into EXEc mode for me to make any necessary changes.

Advertisements
Post a comment or leave a trackback: Trackback URL.

Comments

  • BGP  On October 23, 2011 at 12:22 pm

    hi Daniel ,

    i am here for the configuration that you post for access server i use it but i face a problem my problem is

    I am using a terminal server Cisco 2511 to access my 3 2500 series router and everything is working fine
    I can jump from the access server to any router but when I want to jump back from the router to the access server I have to type control **** 6 x many times to make it work and I can get back but this is horrible.

    i mean in normal way i just need to type control shift 6 x one time or tow times to get back that is but not 20 times or maybe more .

    so pleas of you can help me I’ll be grateful for you this is my configuration:

    Building configuration…

    Current configuration : 1430 bytes
    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname TermServer
    !
    enable secret 5 $1$WdvJ$dCrye5tdXWntAXGbNod8H/
    !
    ip subnet-zero
    no ip domain-lookup
    !
    !
    !
    !
    interface Loopback0
    ip address 1.1.1.1 255.255.255.255
    !
    interface Ethernet0
    no ip address
    shutdown
    !
    interface Serial0
    no ip address
    shutdown
    !
    interface Serial1
    no ip address
    shutdown
    !
    ip http server
    ip classless
    !
    !
    menu access-server text 1 3600 Router
    menu access-server command 1 telnet 1.1.1.1 2001
    menu access-server text 2 Switch-C 1800 series router
    menu access-server command 2 telnet 1.1.1.1 2002
    menu access-server text 3 Switch-C 3600 series (2)
    menu access-server command 3 telnet 1.1.1.1 2003
    menu access-server text 9 Disconnect
    menu access-server command 9 disconnect
    menu access-server text 10 Drop to EXEC mode
    menu access-server command 10 menu-exit
    menu access-server clear-screen
    menu access-server line-mode
    !
    line con 0
    exec-timeout 0 0
    logging synchronous
    autocommand menu access-server
    no exec
    transport preferred lat pad telnet rlogin mop udptn nasi
    transport output lat pad telnet rlogin mop udptn nasi
    line 1 8
    exec-character-bits 8
    no exec
    transport preferred none
    transport input all
    telnet break-on-ip
    telnet ip-on-break
    autohangup
    stopbits 1
    flowcontrol software
    line 9 16
    line aux 0
    line vty 0 4
    no login
    autocommand menu access-server
    !
    end

    • farhad  On March 5, 2013 at 6:02 pm

      Hi I have the same problem

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: